Friday, October 17, 2008

Squirrels at the Zoo

I have been volunteering at the local zoo since July, working mostly with monkeys. At the zoo is a good population of fox squirrels. Some of them are tame, but I haven't had any come to me for handouts yet. I have attached a video featuring one of these squirrels (and lazy tapirs).
video

6 comments:

Anonymous said...

It's nice to see a pro-squirrel blog- thanks. And amen to what you say about liberal/conservative and stewardship of creation!

Tapirs are mostly nocturnal, so you'll have a better chance of seeing them in action if you go to the zoo around sunset or sunrise (of course it may not be open then!). You can find everything about tapirs here: http://www.tapirback.com/tapirgal/

Hodge

Just One Opinion said...

I never cease to be amazed by the number of squirrel sites on the internet! I started one as a sort of tongue-in-cheek response to the invasion of squirrels I ended up with when I put up a bird feeder in my yard. RemoveSquirrels.com isn't really an anti-squirrel site...just a vent for frustration! I have seen some that are actually vehement in their absolute hate of these little guys! Amazing...Anyway, thanks for your posts!

squirrelmama said...

I'm glad to see that the zoo has provided a haven for everyone, including the local squirrels!!! They're not part of any exhibit but are still respected citizens of nature!

Skoticus said...

Hello. This isn't specifically about this post, but...

I am also a squirrel enthusiast, and every week on my blog I feature a squirrel related item as the "Squirrel of the Week." Usually it's art, but this week I have featured your blog as our Squirrel of the Week.

Thanks for all the work you do,
Skoticus
skoticus.blogspot.com

squirrelmama said...

How did the squirrels of Texas survive the winter? Please post and let us know how things are going with everyone.

Anonymous said...

I don't know whether it's just me or if perhaps everyone else experiencing issues with your blog.
It looks like some of the text in your posts are running off the screen.

Can someone else please provide feedback and let me know if this is happening to them as well?
This might be a problem with my browser because I've had this happen previously. Thank you

Here is my webpage :: how to lose weight